Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/content/60/9972860/html/smf/Sources/Load.php(225) : runtime-created function on line 3
Ingester to Bridge - cry for help!
The DAM Forum
Welcome, Guest. Please login or register.
September 20, 2020, 11:52:40 PM

Login with username, password and session length
Search:     Advanced search
28033 Posts in 5147 Topics by 2903 Members
Latest Member: kbroch
* Home Help Search Login Register
+  The DAM Forum
|-+  Software Discussions
| |-+  ImageIngester and ImageVerifier
| | |-+  Ingester to Bridge - cry for help!
« previous next »
Pages: [1] Print
Author Topic: Ingester to Bridge - cry for help!  (Read 7185 times)
sparkle999
Newbie
*
Posts: 3


View Profile
« on: January 19, 2011, 01:09:21 PM »

My first post (and long with it - apologies) - so by way of introduction my name is Nigel Harris, I'm an amateur photographer (UK) and I'm working my way through setting up a workflow to bring some sort of order to my photography collection. I've recently bought a copy of ImageIngester and am struggling with getting the metadata to be picked up (at all) by Bridge. I'm now up to probably my third day of banging my head against this particular problem - I've read up as much as I can on the topic and I'm now declaring myself "stuck". Help would be greatly appreciated!

So, first up, some info:
The XMP sidecar files *are* being generated with metadata in them, however Bridge metadata panel does not show the metadata entered (just blanks).
If I enter metadata into Bridge and save, it overwrites the same XMP file - so it's looking in the right place (looks like a different layout/format though).
I deduce it must be the content of the XMP file that is upsetting Bridge...

I stepped back from my "full blown" metadata setup and went with the "default" entries in II. Same problem - file generated but not appearing in Bridge.
I am now wondering have I inadvertently changed the default setting and caused a problem, or is it something else?

I've read about an issue with the date created  field being blank - it's not, am using
Code:
{@datetime,1,4}-{@datetime,5,2}-{@datetime,7,2}


Here's a sample XMP file that II generated with some test entries in some of the fields (location, city, state, country, job).
Thanks and regards, Nige.

Code:
<x:xmpmeta xmlns:x="adobe:ns:meta/" x:xmptk="3.1.1-112">
   <rdf:RDF xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#">
<rdf:Description rdf:about=""
            xmlns:dc="http://purl.org/dc/elements/1.1/">
         <dc:format>application/vnd.adobe.photoshop</dc:format>
         <dc:subject>
            <rdf:Bag>
               <rdf:li></rdf:li>&lt;rfd:li&gt;</rdf:li>
            </rdf:Bag>
         </dc:subject>
         <dc:description>
            <rdf:Alt>
               <rdf:li xml:lang="x-default"></rdf:li>
            </rdf:Alt>
         </dc:description>
         <dc:creator>
            <rdf:Seq>
               <rdf:li></rdf:li>
            </rdf:Seq>
         </dc:creator>
         <dc:title>
            <rdf:Alt>
               <rdf:li xml:lang="x-default">IMG_20101225_7798</rdf:li>
            </rdf:Alt>
         </dc:title>
         <dc:rights>
            <rdf:Alt>
               <rdf:li xml:lang="x-default"></rdf:li>
            </rdf:Alt>
         </dc:rights>
      </rdf:Description>
<rdf:Description rdf:about=""
            xmlns:photoshop="http://ns.adobe.com/photoshop/1.0/">
         <photoshop:TransmissionReference>test job</photoshop:TransmissionReference>
         <photoshop:Instructions></photoshop:Instructions>
         <photoshop:Credit></photoshop:Credit>
         <photoshop:Source></photoshop:Source>
         <photoshop:Headline></photoshop:Headline>
         <photoshop:City>test city</photoshop:City>
         <photoshop:State>test county</photoshop:State>
         <photoshop:Country>test country</photoshop:Country>
         <photoshop:AuthorsPosition></photoshop:AuthorsPosition>
         <photoshop:CaptionWriter></photoshop:CaptionWriter>
         <photoshop:Category></photoshop:Category>
         <photoshop:SupplementalCategories>
            <rdf:Bag>
               <rdf:li></rdf:li>
            </rdf:Bag>
         </photoshop:SupplementalCategories>
         <photoshop:DateCreated>2010-12-25</photoshop:DateCreated>
      </rdf:Description>
<rdf:Description rdf:about=""
            xmlns:Iptc4xmpCore="http://iptc.org/std/Iptc4xmpCore/1.0/xmlns/">
         <Iptc4xmpCore:CreatorContactInfo rdf:parseType="Resource">
            <Iptc4xmpCore:CiAdrExtadr></Iptc4xmpCore:CiAdrExtadr>
            <Iptc4xmpCore:CiAdrCity></Iptc4xmpCore:CiAdrCity>
            <Iptc4xmpCore:CiAdrRegion></Iptc4xmpCore:CiAdrRegion>
            <Iptc4xmpCore:CiAdrPcode></Iptc4xmpCore:CiAdrPcode>
            <Iptc4xmpCore:CiAdrCtry></Iptc4xmpCore:CiAdrCtry>
            <Iptc4xmpCore:CiTelWork></Iptc4xmpCore:CiTelWork>
            <Iptc4xmpCore:CiEmailWork></Iptc4xmpCore:CiEmailWork>
            <Iptc4xmpCore:CiUrlWork></Iptc4xmpCore:CiUrlWork>
         </Iptc4xmpCore:CreatorContactInfo>
         <Iptc4xmpCore:CountryCode></Iptc4xmpCore:CountryCode>
         <Iptc4xmpCore:SubjectCode>
            <rdf:Bag>
               <rdf:li></rdf:li>
            </rdf:Bag>
         </Iptc4xmpCore:SubjectCode>
         <Iptc4xmpCore:IntellectualGenre></Iptc4xmpCore:IntellectualGenre>
         <Iptc4xmpCore:Scene>
            <rdf:Bag>
               <rdf:li></rdf:li>
            </rdf:Bag>
         </Iptc4xmpCore:Scene>
         <Iptc4xmpCore:Location>test location</Iptc4xmpCore:Location>
      </rdf:Description>
<rdf:Description rdf:about=""
            xmlns:mediapro="http://ns.microsoft.com/expressionmedia/1.0/">
         <mediapro:Status></mediapro:Status>
         <mediapro:Event></mediapro:Event>
         <mediapro:People>
            <rdf:Bag>
               <rdf:li></rdf:li>
            </rdf:Bag>
         </mediapro:People>
         <mediapro:CatalogSets>
            <rdf:Bag>
               <rdf:li></rdf:li>
            </rdf:Bag>
         </mediapro:CatalogSets>
      </rdf:Description>
<rdf:Description rdf:about=""
            xmlns:mediapro="http://ns.iview-multimedia.com/mediapro/1.0/">
        <mediapro:Status></mediapro:Status>
         <mediapro:Event></mediapro:Event>
        <mediapro:People>
            <rdf:Bag>
               <rdf:li></rdf:li>
            </rdf:Bag>
         </mediapro:People>
       <mediapro:CatalogSets>
            <rdf:Bag>
               <rdf:li></rdf:li>
            </rdf:Bag>
         </mediapro:CatalogSets>
      </rdf:Description>
<rdf:Description rdf:about=""
            xmlns:xapRights="http://ns.adobe.com/xap/1.0/rights/">
        <xapRights:Marked></xapRights:Marked>
        <xapRights:UsageTerms>
            <rdf:Alt>
               <rdf:li xml:lang="x-default"></rdf:li>
            </rdf:Alt>
         </xapRights:UsageTerms>
         <xapRights:WebStatement></xapRights:WebStatement>
      </rdf:Description>
   </rdf:RDF>
</x:xmpmeta>
                                                                                                   
                                                                                                   
                                                                                                   
                                                                                                   
                                                                                                   
                                                                                                   
                                                                                                   
                                                                                                   
                                                                                                   
                                                                                                   
                                                                                                   
                                                                                                   
                                                                                                   
                                                                                                   
                                                                                                   
                                                                                                   
                                                                                                   
                                                                                                   
                                                                                                   
                                                                                                   
                           

<!-- XMP sidecar constructed by ImageIngesterPro from template: C:\Users\Nige\AppData\Roaming\Adobe\XMP\Metadata Templates/ImageIngester-IPTC.3.4.xmp -->
Logged
MarcB
Guest
« Reply #1 on: January 19, 2011, 11:57:14 PM »

Hi Nigel,

I hardly use II, but just looking at the XMP generated I can see there's an error in the opening rfd:li tag:

Code:
            <rdf:Bag>
               <rdf:li></rdf:li>&lt;rfd:li&gt;</rdf:li>
            </rdf:Bag>

It looks like a bug in the XMP template (ImageIngester-IPTC.3.4.xmp). Can you create a backup of that, and then change "&lt;rfd:li&gt;" to "<rfd:li>"? That should solve the problem.

Marc
Logged
MarcB
Guest
« Reply #2 on: January 20, 2011, 12:06:47 AM »

and then change "&lt;rfd:li&gt;" to "<rfd:li>"

Actually, that should be ""<rdf:li>" iso "<rfd:li>" (somehow the f and d were swapped in the template as well).

Marc
Logged
sparkle999
Newbie
*
Posts: 3


View Profile
« Reply #3 on: January 20, 2011, 01:31:39 PM »

Marc, thanks so much for spotting that - I missed that completely.

I think I need to take a few steps backwards before going forwards...

The default XMP template held in Adobe/XMP/Metadata Templates has the following line which ends up turning into the erroneous code that you highlighted:

Code:
            <rdf:Bag>
               <rdf:li>{@IPTC.Keywords}</rdf:li>
            </rdf:Bag>

So I am not sure if this is a bug, or just me!
I originally installed the very latest version of II (v3.5.01) on Vista x64. As part of my fault finding, I then regressed to v3.4.10.
Perhaps I didn't uninstall properly. I'll have a go at clearing out all the templates and starting from scratch with v3.4.10 and see what gives.

Regards, Nige
Logged
sparkle999
Newbie
*
Posts: 3


View Profile
« Reply #4 on: January 20, 2011, 02:16:52 PM »

Solved. Perfect. Thanks for your help.

Occam's razor at work again - my fault... I had indeed inadvertently introduced an error with the default setting - which corrupted the generated file.

Interesting though that uninstalling and reinstalling doesn't fix this kind of problem:

I've established that uninstalling II leaves the AppData/Roaming/Adobe/XMP/Metadata Templates  and AppData/Roaming/ImageIngesterPro folders intact - which is fair enough I guess - you probably wouldn't want to lose your settings if you uninstall then reinstall a newer version. So I cleared them out - just in case I'd accidentally messed something up. Then reinstalled.

I wonder whether the default settings should be made "read only"....to protect against users like me Smiley
Logged
MarcB
Guest
« Reply #5 on: January 21, 2011, 02:35:14 AM »

Excellent, good to hear you've got it all working again! Marc Rochkind recently asked people if they had any feature requests for the new version of II (see http://thedambook.com/smf/index.php?topic=4955.0), so perhaps you can ask him to add a feature to optionally uninstall the templates as well.

Marc
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!