Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/content/60/9972860/html/smf/Sources/Load.php(225) : runtime-created function on line 3
Save metadate not working?
The DAM Forum
Welcome, Guest. Please login or register.
August 15, 2020, 12:28:16 AM

Login with username, password and session length
Search:     Advanced search
28033 Posts in 5147 Topics by 2904 Members
Latest Member: kbroch
* Home Help Search Login Register
+  The DAM Forum
|-+  Software Discussions
| |-+  Lightroom
| | |-+  Save metadate not working?
« previous next »
Pages: [1] Print
Author Topic: Save metadate not working?  (Read 3323 times)
John nf
Newbie
*
Posts: 8


View Profile
« on: April 26, 2009, 06:17:54 PM »

I am getting the  "Down arrow" indicating that metadata needs to be saved, even right after saving. Tried multiple saves, shutting down and restarting. Seems to be a problem only with the last batch of photos shot in the last few days. The metadata is correct when I look at it. Thinking of reinstalling LR but the problem could be the catalog. Any ideas?  Using LR 2.3 on a Mac, OS 10.5.6, nikon D100.

thanks for any and all help,
John
Logged
peterkrogh
Administrator
Hero Member
*****
Posts: 5682


View Profile Email
« Reply #1 on: April 26, 2009, 07:58:19 PM »

John,
The metadata mismatch indication can be too touchy, I think.
Have you tried to optimize the catalog?
Peter
Logged
John nf
Newbie
*
Posts: 8


View Profile
« Reply #2 on: April 27, 2009, 05:04:20 AM »

Peter,
Thanks for the suggestion. I tried it this am and no luck. I also re-installed a fresh copy of LR 2.3 last night, no change.
I am tempted to ignore this as the changes are being recorded, LR just doesn't think so. What does anyone out there think? Anyone else seen this bug?

John
Logged
DMJMich
Newbie
*
Posts: 5


View Profile
« Reply #3 on: July 14, 2009, 03:25:08 PM »

After experiencing the same problem, I was fortunate to find a solution through Adobe's LR Forum. Here is my report.

The solution was provided by Ian Lyons, a Community Expert on Adobe’s LR Forum. Another regular Adobe Forum participant, Jao vdL, observed, “When something is wrong with the catalog file, it is often hard to fix." The thread may be found under the title, "How to fix saving of metadata changed in LR".

I would be glad to upload a more complete report of the problem, measures tried and a detailed list of steps followed for resolution. "Attachments" is not present under Additional Options...

In summary, copy the problem photo, import, copy metadata to the copy, remove original from catalog, synch folder to reimport, copy metadata back to original, save metadata on original.

Specific steps:
1.   In Finder, make a copy of the problem photo.
2.   In LR, in the Library module, import the copy into the catalog.
3.   Copy the metadata from the original.
4.   Paste the metadata into the copy.
5.   Remove the problem file from the LR catalog (do not delete from disk).
6.   Do Library>Synchronize Folder to reimport the original photo.
7.   Copy the metadata from the copy.
8.   Paste the metadata into the original.
9.   Select the reimported original and save metadata to file.
10.   Delete the copy from the disk.

Confirm downward arrow badge is no longer present for the formerly problem photos.

Since this is a single case, your results may not match mine. The process, while painstaking, saved my images, appears to have cleared up catalog corruption and restores sound sleep, not to mention making me more confident about the quality of the copies of my catalog.

Doug Johnson
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!