Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/content/60/9972860/html/smf/Sources/Load.php(225) : runtime-created function on line 3
Color Management issues using NEFs
The DAM Forum
Welcome, Guest. Please login or register.
December 11, 2019, 07:42:17 AM

Login with username, password and session length
Search:     Advanced search
28033 Posts in 5147 Topics by 2904 Members
Latest Member: kbroch
* Home Help Search Login Register
+  The DAM Forum
|-+  Software Discussions
| |-+  Media Pro & Expression Media
| | |-+  Color Management issues using NEFs
« previous next »
Pages: [1] Print
Author Topic: Color Management issues using NEFs  (Read 7146 times)
Massimo Novi
Newbie
*
Posts: 36


View Profile
« on: March 27, 2009, 04:24:18 AM »

Hello

I am re-evaluating color management in EM 2.0.2096 (Windows) after MS last fixes.

On NEF files the WIC and Manifacturer (QT or Nikon SDK Libraries?) seems to DIFFER in honoring color spaces.

Using WIC settings (Color Match active) NEF thumbnails are different from NX2 and seems NOT to apply ANY color space (dull color).

The Color Space specified in the NEF was AdobeRGB.

The Manifacturer setting (Color Match active) seems however to honor the AdobeRGB color space BUT when Media View is active and the Light Table is opened, the Media View color CHANGES to a more saturated hue (moving the Light Table window deletes the image and redraw it with this saturated effect). The Light table view seems to honor the AdobeRGB space but the Media View remains saturated even after exiting and reopening EM.

So: using WIC gives NO color space render on NEF. Using Manifacturer is OK on color space BUT has problems with Light Table.

Obviously using DNG and internal previews solves this problem but I would like to know if anyone found that Nikon WIC Codec (1.6.0) has no wai to honour color spaces or if EM has a problem in the dialogue with it.

Thank for any contribute to this issue. Anyone noted it or can reproduce it (Windows XP SP3)?

Massimo

Logged
Absolute Chaos
Jr. Member
**
Posts: 68


View Profile
« Reply #1 on: March 28, 2009, 12:56:28 AM »

I'm on a mac, but I have color management issues with TIFFs in EM2 build 2096.

I'd recommend contacting customer service.

Looks like I discovered the bug. (I hope they won't name it after me, I'd rather give my name to a star)

I have the impression, that the previews rendered by EM2 are faulty for large files.

-Robert
Logged
peterkrogh
Administrator
Hero Member
*****
Posts: 5682


View Profile Email
« Reply #2 on: March 28, 2009, 02:33:37 PM »

These are likely to be to entirely different issues. The Mac is using Quicktime to render, and, while you can use Quicktime on the PC, Massimo is using WIC.

Peter
Logged
Massimo Novi
Newbie
*
Posts: 36


View Profile
« Reply #3 on: March 30, 2009, 05:23:07 AM »

Peter,

I tested on Windows XP SP3 and found color issues on JPEG and TIFFs.

1) Using JPEGs and TIFFs (8-16 bit) are NOT color managed in previews. Previews used online (setting Display Previews at all times) and offline (disconnetting the external HD) are always OVERSATURATED with OFF colors. Using a color space like ProPhotoRGB (very large) shows clearly this issue. May be less noted using AdobeRGB or sRGB.

2) Using NEF fles with WIC (Nikon Codec 1.6.0) is NOT COLOR MANAGED. The problem can be clearly noted with NEF files taken with AdobeRGB (Mode II) profile setting on camera. sRGB NEF files (Mode I and III on camera) seem to be color managed. Preview does not go OFF COLOR but is anyway NOT COLOR MANAGED.

3) Using NEF files with Manifacturer engine shows a good color management even with AdobeRGB NEFS BUT the Media View is ROTATED. However the Preview has the same OFF COLOR problem of JPEG and TIFFs.

To test NEFs I used the Mode II setting on a Nikon camera (the profile name written into the NEF is AdobeRGB) so on screen the colors clearly appear lightly "undersaturated" if not color managed.

To test JPEG and TIFFs (I used the ProPhotoRGB color space for TIFFs and JPEGs for tests) I clearly see OFF COLORS in previews.

Have You ever had and/or reproduced these issues on Mac?

Note: DNG and PSD formats are correctly color managed even in previews.

I opened a topic on EM Forum to ask MS Support more info. I will inform the Forum if and when these issues will be reproduced by MS.

Massimo



Logged
Massimo Novi
Newbie
*
Posts: 36


View Profile
« Reply #4 on: March 31, 2009, 02:23:43 AM »

Hello

EM bugs on Preview color management has been confirmed and filed by MS. They are testing more on NEFs behaviour.

The suggested workaround on Windows is to work online and NOT activate "Display Preview at all times".

Massimo
Logged
Massimo Novi
Newbie
*
Posts: 36


View Profile
« Reply #5 on: April 01, 2009, 01:20:15 AM »

Hi,

MS confirmed that Previews on TIFs and JPGs are NOT color managed so using EM for OFFLINE image selection is pratically useless (images are off color). Online views are ok (NOT using Light Table however). NEFs are not color managed.

MS says that has no release plans for a SP3 at this moment. For me the preview color management issue on EM is CRITICAL.

I am evaluating a strategy to use EM 2.0 on DAM workflow even with this glitch but is not easy (using ProPhotoRGB profile for master and print file makes things worse).

Any idea?

Massimo
Logged
snah
Newbie
*
Posts: 5


View Profile
« Reply #6 on: August 03, 2010, 04:43:24 PM »

Massimo,

have you found a workaround or even a solution to the NEF rendering problem in EM2 as you have described it?
I've got the same problem (actually its an EM2 problem). so far I lived with it, but I begin to find it confusing and hope for an answer.

Thanks, Hans.
Logged
peterkrogh
Administrator
Hero Member
*****
Posts: 5682


View Profile Email
« Reply #7 on: August 04, 2010, 04:50:56 PM »

Hans,
Are you using a wide-gamut monitor?
Peter
Logged
Massimo Novi
Newbie
*
Posts: 36


View Profile
« Reply #8 on: August 05, 2010, 05:28:50 AM »

Hans,

I have not found a workaround yet. Offline TIFF/JPEG images can be viewed on any monitor but they are not color managed in EM 2.0.

I can live with this issue but is strange that color management is so "hard" to implement fully...

By the way, using a wide gamut monitor will render AdobeRGB images almost ok (because are nearest to the monitor profile gamut) but sRGB images will be over-satured.

Viceversa, for the sRGB-gamut monitors (sRGB offline images are ok but AdobeRGB images are duller).

Until PhaseOne will abdress this issue, the problem will persist. I hope PO inherited the issue list form MSoft, but to be sure, could kindly Peter Krogh ask for this issue to them (he talks to them often, I suppose)?

Massimo
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!