Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/content/60/9972860/html/smf/Sources/Load.php(225) : runtime-created function on line 3
Anybody using GeoSetter with DNG files?
The DAM Forum
Welcome, Guest. Please login or register.
January 17, 2021, 03:48:20 PM

Login with username, password and session length
Search:     Advanced search
28033 Posts in 5147 Topics by 2903 Members
Latest Member: kbroch
* Home Help Search Login Register
+  The DAM Forum
|-+  General
| |-+  GPS/ Geotagging
| | |-+  Anybody using GeoSetter with DNG files?
« previous next »
Pages: [1] Print
Author Topic: Anybody using GeoSetter with DNG files?  (Read 8948 times)
jayp
Newbie
*
Posts: 25


View Profile
« on: August 23, 2008, 01:31:32 PM »

I just discovered GeoSetter this morning and it looks amazing! However I'm having a problem saving files.

I'm working with .dng files on Vista Ultimate. Whenever I make any change to a file, it saves fine the first time. All subsequent attempts to edit anything in the file and save it produce error messages like so:

Error: Can't read ProfileIFD data - C:\Users\jay\Desktop\jpacker_080619_6225.dng

I've tried changing the GeoSetter settings of how .dng files are handled to various different options. I've run the program as an administrator. Nothing works. I can't edit a file more than once... I even used ImageIngester to call the DNG converter and verify that my DNG files were valid, both before and after being saved by GeoSetter. In both cases they are.

I believe this is a problem more with ExifTools, the utility that GeoSetter uses to write information to the file. In fact, GeoSetter's documentation clearly explains that any errors regarding saving a file are coming from ExifTools, not GeoSetter. (Still doesn't mean that GeoSetter couldn't have a problem with it's implementation of ExifTools).

I tried searching the ExifTools site, GeoSetter's help files, and the web, but no luck. I've also put in an email to both authors of these tools.

I'm asking here because it would be nice if someone has a solution (okay, probably not likely) but also it would be helpful to know if anyone else is having these problems. If everyone else can use DNG files with GeoSetter, then the problem must be something unique to my system or files... If someone else has noticed these problems (or can reproduce them), then that would at least tell me that it's a bug.

Thanks.
Logged

Jay Packer
johnbeardy
Administrator
Hero Member
*****
Posts: 1813


View Profile WWW
« Reply #1 on: August 23, 2008, 01:39:14 PM »

I do, but with XP, and with no problems. The best thing will probably be to wait for the developer of Geosetter to respond .

John
Logged
Jean-François Schmitz
Newbie
*
Posts: 13


View Profile
« Reply #2 on: September 02, 2008, 08:46:41 AM »

I'm using it occasionally with Vista and I can't remind having run into trouble - but then, I normally just write the geo tags just once with GeoSetter, then do the further keywording etc... in Lightroom.

Actually, I normally geotag from GPS traces (in GPX format) when ingesting with ImageIngester Pro. I only use Geosetter when I don't have a GPX trace at hand, because it is incredibly easy to use to geoset "manually" on a Google map. Also, one of the GPS devices I use doesn't provide altitude information in the GPX, and here also Geosetter comes in handy to quickly look up a bunch of coordinates and pull the altitude in the EXIFs.

Jean-François (JF in short  Wink)
« Last Edit: September 02, 2008, 11:58:11 AM by Jean-François Schmitz » Logged

--
Don't dream it!
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!