Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/content/60/9972860/html/smf/Sources/Load.php(225) : runtime-created function on line 3
Removing Keywords
The DAM Forum
Welcome, Guest. Please login or register.
December 11, 2019, 06:46:53 AM

Login with username, password and session length
Search:     Advanced search
28033 Posts in 5147 Topics by 2904 Members
Latest Member: kbroch
* Home Help Search Login Register
+  The DAM Forum
|-+  Software Discussions
| |-+  Media Pro & Expression Media
| | |-+  Removing Keywords
« previous next »
Pages: [1] Print
Author Topic: Removing Keywords  (Read 2999 times)
rcannonp
Newbie
*
Posts: 45


View Profile Email
« on: May 16, 2008, 06:54:53 AM »

I'm not sure if this is a bug or if I'm just not doing it properly. I decided that keywords that I had assigned to some files weren't appropriate.  I tried to remove them in couple of different ways, but the files still show up under the keywords that were previously assigned to them. First I tried deleting them in the Info panel. Then I tried the Clear Annotations action. I restarted EM, but they still showed up. I then restarted the whole system, and they still show up. Am I doing this the right way? It seemed pretty straight forward.

–Cannon
Logged

15" MBP :: OS 10.5.6 :: Lightroom 2 :: C1 Pro 3.7 :: CS3 :: EM2
iau
Newbie
*
Posts: 11


View Profile
« Reply #1 on: May 17, 2008, 01:38:18 AM »

Hi,

If the keywords are embedded in the file I think you have to export your new annotation fields back to the file. If not Expression Media will just reread the annotations from the file if you synch back from the file again. I've found the easiest way to do this from the Info pane since the selected files will "disappear" from your view once you remove the keyword in the Organize pane.

In addition you may want to delete the term from you keyword list, if you are no longer using the keyword at all.

- iau
Logged
rcannonp
Newbie
*
Posts: 45


View Profile Email
« Reply #2 on: May 17, 2008, 05:19:55 AM »

Thanks for the reply.

The removed keywords don't show up in any of the fields related to the file(info, keyword field in thumbnail view). When I select the keyword in the list, then the files that had that keyword previously assigned to them show up there even though they don't seem to have that keyword assigned to them any more. I've tried clearing the annotations and syncing them but the files still show up under the unassigned keyword. After syncing the annotations, I checked the files in Bridge and found that the keywords do seem to be properly applied.

–Cannon
Logged

15" MBP :: OS 10.5.6 :: Lightroom 2 :: C1 Pro 3.7 :: CS3 :: EM2
peterkrogh
Administrator
Hero Member
*****
Posts: 5682


View Profile Email
« Reply #3 on: May 17, 2008, 07:27:39 AM »

Cannon,
You might try to rebuild the catalog.
Make a new blank catalog
Select all images in the existing catalog
Drag to the new catalog.

See if the problem persists.
Peter
Logged
rcannonp
Newbie
*
Posts: 45


View Profile Email
« Reply #4 on: May 17, 2008, 08:36:58 AM »

OK. I didn't realize that Keywords and Hierarchical Keywords are separate things. It was Hierarchical Keywords that I was having problems with. Still, I would think that Clear Annotations would clear that out as well, but apparently not. I deleted the term and then reapplied it to the items that I wanted associated with it. I would think that there would have to be an easier way to delete Hierarchical Keywords from media other than deleting the Hierarchical Keyword from the catalog.

–Cannon
Logged

15" MBP :: OS 10.5.6 :: Lightroom 2 :: C1 Pro 3.7 :: CS3 :: EM2
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!