Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/content/60/9972860/html/smf/Sources/Load.php(225) : runtime-created function on line 3
D3 Xmedia Workaround
The DAM Forum
Welcome, Guest. Please login or register.
November 16, 2019, 02:14:12 PM

Login with username, password and session length
Search:     Advanced search
28033 Posts in 5147 Topics by 2904 Members
Latest Member: kbroch
* Home Help Search Login Register
+  The DAM Forum
|-+  Software Discussions
| |-+  Media Pro & Expression Media
| | |-+  D3 Xmedia Workaround
« previous next »
Pages: [1] Print
Author Topic: D3 Xmedia Workaround  (Read 3939 times)
Kent Larson
Newbie
*
Posts: 15


View Profile Email
« on: January 02, 2008, 08:20:19 AM »

Below is what I have received from iView support as a workaround for getting Expression to see the D3 raw files.  I have asked what to do for a Mac.

All of you are on your own with this workaround, I can't support you.  I suggest you contact iView/Expression support directly if you have questions.  I'm sure all of us would love to hear experiences from those of you willing to experiment.

Thanks, and good luck!

===============================
I mentioned previously that any fix that becomes available would be available on Expression Media and not MediaPro, and that is precisely what has happened.

Basically, on Expression Media with Service Pack 1 we can leverage the Windows Imaging Component (WIC), which gives us a way around the issue.

You will have to do the following:
1) Install Expression Media SP1 on your machines. Please go to the following URL:
http://www.microsoft.com/expression/products/download.aspx?key=media
and follow the links to download Expression Media SP1.
2) Download and install the latest Nikon codec. You can get this from the following URL:
http://www.nikonimglib.com/nefcodec/
You will note that it was written for Windows Vista, but it appears to work just fine unders Windows XP.
3) If you are not familiar with editing your registry, please refer to:
KB322756 - How to back up and restore the registry in Windows XP and Windows Vista (http://support.microsoft.com/KB/322756)
for information on how to back up your registry.
4) Please do the following to force Media to use WIC:
   4.1) Go to Start --> Run and type in regedit on XP (or type regedit in the search box on Vista).
   4.2) Navigate to HKey_Current_User\Software\Microsoft\Expression\Media\1.0
   4.3) On the Edit menu, click New --> String value setting the name as WICExclude
   4.4) Double-click on the string value entry and set the string to
           MRW,RAF,MOS,STI,EXIF,DCR,X3F
   4.5) Click OK.

You should now be able to import the images with no issues into Expression Media.

Please note the following: by using the above workaround, you may not see the color profile info for your JPEG (and other) files as WIC handles that information differently. If this an important issue for you, you simply need to add the file extensions for the file types that you would like to exclude from WIC to the above string you entered. To do this you would simply follow the steps above, and then double-click on the WICExclude value you added previously and change the string there to something like:
       MRW,RAF,MOS,STI,EXIF,DCR,X3F,JPE,JPG,JPEG
where you have added the file extension you would like to be handled by QuickTime and not WIC (in this case we added the varios extensions used by JPEG files).

I hope the above information has been helpful to you. The above information will be made publicly available in a future knowledge base article (KB946333), but the KB is currently still under internal review and cannot be accessed publicly.

Please let me know if you have any issues with D300 files and Expression Media SP1 after applying the above fixes.

=============

Kent
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!